LanguageTool : un correcteur grammatical pour OpenOffice

Le correcteur  grammatical opensource LanguageTool est livré sous la forme d’un simple fichier oxt, c’est donc une extension  non incluse dans la version de base d’OpenOffice. Pour le tester il est nécessaire de procéder à son installation. Attention, Java doit être installé au préalable à partir de cette adresse.

Selon votre version d’OpenOffice (Menu Aide, A propos) téléchargez  l’extension correspondante (rubrique Download du site LanguageTool), préférez le choix “Enregistrer-sous”. Ouvrez OpenOffice, par exemple le traitement de texte Writer, puis cliquez sur Outils, Gestionnaire des extensions. Cliquez le bouton Ajouter, sélectionnez le fichier oxt, activez l’extension “seulement pour vous” ou “pour tous les utilisateurs”. Redémarrez OpenOffice.

Si l’installation s’est correctement déroulée, un nouveau sous-menu est présent dans Outils : LanguageTool. Pour fixer la langue “maternelle”, activez le sous-menu Configuration puis choisissez Français dans la liste.

Tout est prêt, un petit test s’impose : Les enfant perde leur temps à joué.

image

Après quelques secondes, un soulignement bleu fait son apparition sous le sujet, clic droit et le menu contextuel commente un problème d’accord.

LanguageTool ne donne pas la solution mais pointe l’incohérence. Après correction manuelle, le verbe non accordé est souligné.

Limite de l’outil joué s’écrit à l’infinitif, LanguageTool ne voit rien du tout. Sur des phrases complexes, les conseils affichés s’avèrent même complètement incohérents.

Bien que l’on attendait pas de miracle – la grammaire française étant difficilement modélisable – les premiers essais sont assez prometteurs et éviteront peut-être quelques étourderies.

A installer par curiosité….

Ce contenu a été publié dans Logiciels, Openoffice, Ressources Pédagogiques, avec comme mot(s)-clé(s) . Vous pouvez le mettre en favoris avec ce permalien.

9 réponses à LanguageTool : un correcteur grammatical pour OpenOffice

  1. jules dit :

    bonjour et bien moi j ‘ai open office 2-3 et quand je veut installer languagetool est bien c ‘est écrit impossible d ‘installer l ‘extension, car les dépendances systémes suivantes ne sont pas respectées
    open office.org3.01 (j ‘ai pratiquement suivie à la lettre vos cnseille mais j’ai pas compris cette étape version d’OpenOffice (Menu Aide, A propos) téléchargez l’extension correspondante (rubrique Download du site LanguageTool), préférez le choix “Enregistrer-sous” si vous pouvez m’expliquer (même si qu ‘il est vrai que c ‘est très bien expliquer mais j ai pas compris )
    merci

    • Tic & Net dit :

      Bonjour,
      Merci de l’intérêt que vous portez à Tic & Net. Quand vous téléchargez l’extension, clic droit puis enregistrez la cible du lien sous….
      cdlt

  2. jules dit :

    vous n ‘auriez pas une solution 🙂

  3. jules dit :

    merci à vous même si j ‘arrive pas sa fonctionne pas sur mon truc breff

  4. jules dit :

    merci de votre gentillesse merci énormément 🙂

  5. dominiko dit :

    :: Limite de l’outil joué s’écrit à l’infinitif, LanguageTool ne voit rien du tout.

    La dernière version voit bien que « joué » devrait être à l’infinitif. LT indique :

    Message: Le verbe « joué » devrait être à l’infinitif après la préposition « à »

    J’utilise la dernière version snapshot (nightly build) :
    http://www.languagetool.org/download/snapshots/

    LanguageTool ne voit pas tout, mais il s’améliore continuellement petit à petit. Si tu vois des erreurs non-détectée, n’hésite pas à les signaler. Je peux ajouter des règles.

  6. omer dit :

    Bonjour,
    Je viens d’installer Launguage Tool, sans difficultés, et cette version a trouvé la faute à “joué”.
    Bravo !

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *